Author: Eriksson Joakim, Teknikhuset AB.

Published: 2002-10-24

Applies to: Content Studio 3.2 - 5

Type: Information


Symptoms

An administrator changes a user's group membership in a domain or in the local server but the changes are not reflected in Content Studio.

Cause

This problem is due to the caching of security properites both in Windows and in Content Studio. A change of group membership does not take effect in Windows until the user logs off and logs on again. In Content Studio the user's group membership is updated when the user's session expires and she opens a new one. Content Studio caches sessions for approximately 60 minutes of inactivity and during that time all requests for a new session will retrieve the already cached session information, which has not been updated.

Resolution

Ask the user to log off all her Windows sessions. In Content Studio under the "Users and Groups" click "Users in CS" button and locate the user in question. Open the user properties dialog box by double clicking on the user in the list. In this dialog click the "Close session" button. This causes Content Studio to open a new session for the user the next time she does something in Content Studio. Alternatively you can ask the user to exit all her instances of Content Studio, not by just closing the browser, but by clicking the Exit command in the File main menu. Eventually, when all affected users has logged off from Windows and their session has timed out (i.e. from one day to another) the change will be reflected in Content Studio.

Status

This is by design due to the caching of security properties in Windows and in Content Studio.